Back to overview
Maintenance
server restart
Mar 23, 2026 at 8:20pm UTC
–
Mar 23, 2026 at 9:10pm UTC
Affected services
DualHosting node01
Resolved
Mar 23, 2026 at 8:20pm UTC
this will take about 20 minutes
Affected services
Resolved
Mar 23, 2026 at 8:20pm UTC
this will take about 20 minutes
Affected services